IP3 - Control Software
Ver. 3.0.2 CR

Short description Manual

Confidential

Preliminary

Document version: 1.0

1.1.1 Document history

<table>
<thead>
<tr>
<th>Chapter</th>
<th>Version</th>
<th>Changes</th>
<th>Date</th>
<th>Author</th>
</tr>
</thead>
<tbody>
<tr>
<td>All</td>
<td>1.0</td>
<td>New Revision</td>
<td>07.02.2005</td>
<td>DB</td>
</tr>
</tbody>
</table>
Table of Contents

1  INTRODUCTION TO IP3 - CONTROL .................................................................3
   1.1  FUNCTIONAL DESCRIPTION ........................................................................3
   1.2  SPECIFICATIONS .........................................................................................3

2  GETTING STARTED ............................................................................................4
   2.1  THE FIRST IMAGE .......................................................................................5

3  SOFTWARE FUNCTIONS .....................................................................................6
   3.1  ADJUSTING THE IMAGES ...........................................................................6
      3.1.1  Digital Image Stretch ............................................................................6
      3.1.2  Additional FPN Correction .................................................................9
      3.1.3  Color Settings ......................................................................................10
      3.1.4  Color Saturation ..................................................................................10
      3.1.5  White Balance .....................................................................................11
      3.1.6  Pixel Color Correction ........................................................................12
   3.2  INTEGRATION LENGTH WINDOW ..........................................................12
   3.3  HISTOGRAM ...............................................................................................13
   3.4  FILE I/O ......................................................................................................14
      3.4.1  Load Image ..........................................................................................14
      3.4.2  Save Image ..........................................................................................14
   3.5  ZOOM FUNCTION .......................................................................................15
   3.6  MOVIE ........................................................................................................17
      3.6.1  Movie Player .......................................................................................17
      3.6.2  Recording Sequences .........................................................................18
   3.7  CAMERA CONTROL ..................................................................................19
   3.8  INFO ...........................................................................................................19
2 Introduction to IP3 - Control

2.1 Functional Description

The IP3 - Control software is specially designed for HDRC image post processing and sensor independent. The software supports b/w and color cameras. The frame grabber fetches every image from the HDRC camera and store it via DMA into the PC main memory. The grabbing frame rate depends on the camera system pixel clock. e.g. a 12 MHz pixel clock with standard settings has a frame rate of 31 fps.

The image processing and displaying is very time intensive, so the displayed frame rate depends especially on the performance of the used PC system. The software performance will be also influenced by the activated image operations, e.g. histogram displaying, color saturation, FPN correction, .... . So the displayed frame rate is not an indicator of the real HDRC camera frame rate.

The software runs independent from the frame grabber image acquire system.

2.2 Specifications

The startup frame settings of IP3 Control are:

Start position x: 8
Start position y: 75
Width: 640
Height: 480

The frame grabber image data format is set to 10 bit. So the LSB and LSB+1 of the 12 bit sensor data are cut.

The software supports only Eltec’s PCEYE3 LVDS frame grabber. Condition for the correct working of the software is that Eltec’s PCEye3 frame grabber software driver has been already installed.
3 Getting Started

After you executed the IP3 - Control software you will see these application windows. The software starts automatically in grey display mode.

Figure 1: Start up Windows of IP3 Control
3.1 The First Image

To take a single image select in the main menu: Acquisition ⇒ Snap. To get a live image displayed, select in the main menu: Acquisition ⇒ Grab.

If you connected a color camera, switch on the color function by selecting Show ⇒ Color Format ⇒ Color.

It is possible that the image may appear too dark or too bright. To get an optimal displaying contrast of the image, select one of the stretch function in the LUT Properties window (see also 3.1.1).

To get the optimum image quality it is recommended to load an existing or create a new FPN correction file. The FPN correction functions are available in the Image Correction window, select in the main window Settings ⇒ FPN Correction…. (see also 3.1.2). The FPN correction should make at the average scene and typical illumination you want to record images.

If you want to integrate about a defined count of images press Acquisition ⇒ Integrate Snap.

The default value of integrated frames is 32. To change this value select in the main menu Settings ⇒ Integration Lenght… (see also 3.2).
4 Software Functions

4.1 Adjusting The Images

The camera data includes the information about the whole dynamically range. That is why the displayed image is probably not optimal to the actual contrast of the scene. The software offers possibilities to adjust the displayed image to get the best on screen result.

There are three possibilities to adjust the image:
- Digital Image Stretch
- Additional FPN Correction
- Color Settings

4.1.1 Digital Image Stretch

The used digital image stretch in this software is a combination of two operations:
- Optimal contrast adjustment
- Data width reduction

The grabbed images have a 10 bit resolution. But only 8 bit of this data can be shown on the monitor. Normally a linear transformation is used to convert 10 bit data to 8 bit data. The plainest way is to cut 2 LSB and to display the 8 MSB, because these bits contain the most important illumination data.

The program offers three other possibilities to adjust an optimum contrast of the image for screening by using the whole HDRC solution:
- Linear Stretch
- Min. – Mean – Max Stretch
- Gamma Stretch

![LUT Properties Window](image)
“Linear” mode
The minimum 10 bit value is linear mapped to 0 and the highest value of the maximum 10 bit value to 255 of the 8 bit Display data. Between the min and max value is a linear transformation done.

“Min-Mean-Max” mode
This mode offers additional the opportunity to use an intermediate value. This value lies between the min and max and is mapped onto the medium grey value (=128). All values between min. and the medium grey value are mapped linear onto the range of 0 and 128. The other values are mapped linear onto 129 and 255.
If you use the “Min-Mid-Max” modus we recommend setting the “Gray Level” value for about 15-30% of the range between “Black Level” and “White Level”.

“Gamma” mode
The minimum 10 bit value is linear mapped to 0 and the highest value of the maximum 10 bit value to 255 of the 8 bit Display data. Between the min and max there is used a gamma correction transfer curve. For gamma values less than 1, the transformed image will have less bright colors than the original image. For a gamma value equal 1, a linear transformation is done.

“Threshold” mode
The image will be displayed binary. All values above the threshold value will be set to 255 the others to 0.

The “Reset”-Button set the “Input Range” and the “Output Range” to its start up values.
The auto / single adjust algorithm ascertains the setting values dependent on the “Corrected Data” histogram statistic.
The track bar “Refresh Rate ..” allows the user to control the auto adjustment speed.
Default refresh rate of the LUT is after every 5. image.
The refresh rate of the LUT function display is every second and it is asynchronous to the really update and new calculation rate of the used LUT.
The software offers three different auto adjustment functions:
- “Min-Max” stretch
- “Min-Mean-Max” stretch
- “Gamma” stretch

The gamma value of the “Gamma” stretch mode depends on statistically results of the actually histogram and will be adapted after every new statistic calculation.

Figure 3: LUT Properties Window – Auto Range Adjust
4.1.2 Additional FPN Correction

This FPN correction is software based with full raw image 10 bit resolution. There are two possibilities for FPN correction:

- One Measurement Point
- Threshold Method

The image integration frame count can be set in the “Integration Setting” window.

( Main Menu ⇒ Settings ⇒ Integration Length…. )

![Image Correction Window](image)

The program can handle several FPN corrections at one time. The FPN correction can be changed during grabbing operation.

To save an FPN correction to file, select one and store it, File ⇒ Save Selected FPN.

It is also possible to load a FPN correction from file created in the past, Image Correction Menu ⇒ FPN ⇒ Load FPN ....

An existing FPN correction entry can be deleted by pressing the button “Delete Entry”

4.1.2.1 How to do it

Stop at first continues image acquisition.

- One Measurement Point

  At first the lens has to be covered by a white diffuser filter which produces an homogeneous illumination for all pixels.

  Choose CreateFPN ⇒ One Point FPN as FPN correction method

  After that a sequence of images is grabbed and its average image is calculated. The mean value of the average image is ascertained. This mean value will be subtracted pixel wise from the average image (= fpn image).

  The fpn image is subtracted pixel wise from every new grabbed image.
• Threshold
  Plug a black cap before the lens and start the FPN correction creation
  CreateFPN ⇨ Threshold.

  At first the program will prompt you to cover the lens with a black cap
  and second to cover the lens with a homogenous grey filter.
  The “Threshold Method “needs two images, a dark and the bright image
  for the FPN calculation. Going out from this two FPN images the algorithm
  ascertain for each pixel the optimum FPN value.

4.1.3 Color Settings
  To get the best color image at every lightning condition, the program offers some
  abilities for color adaption:

  • Color Saturation
  • Pixel Color Correction
  • White Balance Calibration

4.1.4 Color Saturation
  If the Color Saturation is active, the color intensity can be controlled by the scroll
  bar for red, green and blue color channel. The color saturation functions will
  display the colors more saturated. If a value set one, then this color will not
  amplified.
  As common values for Red, Green and Blue we recommend two.
  To open the Color Correction window, select in the main menu
  Settings ⇨ Color Correction …

![Figure 5: Color Setting Window]

**Paying Attention:**

  • The settings for color saturation and its result image is very subjective and
    dependents on the actual illumination of the scene.
  • The color calibration or model (ctr or lcd type) of the monitor has a huge in-
    fluence of the displayed color image quality.
4.1.5 White Balance

Digital cameras require a careful adjustment of the red, green, and blue signal settings to identify a white object as white even if the scene lighting resp. the color temperature change.

A white balance function is implemented in the software.

White balance can be performed automatically (Color Setting Window ⇒ Calibration ⇒ White Balance Calibration) or set manually in the Advanced Color Setting Window (Color Setting Window ⇒ Advanced Settings) by changing the red, green and blue offset values.

![Figure 6: Stretched Image and its histogram without white balance calibration](image1)

![Figure 7: Stretched Image and its histogram with white (grey) balance calibration](image2)
4.1.6 Pixel Color Correction

This function influences the pixel color directly. It is possible to intensify or understate the incoming log. color pixel value or to add resp. subtract an offset value.

The pre-corrected pixel values will be used for Color Saturation.

![Advanced Color Setting Window](image)

4.2 Integration Length Window

The integration length value defines the number of images, which are grabbed in an integration sequence. The image integration value is used by the creation of the software FPN correction routine or by the “Integrate Snap” function in the main menu item “Acquisition”.

![Integration Setting Window](image)
4.3 Histogram

A histogram shows the distribution of pixel values in an image. It can be used to optimize the information in the image. Switch on the histogram function by selecting Show ⇒ Histogram. The histogram will be displayed in log scale.

![Histogram](image)

There are two histograms available, the first histogram shows the statistic distribution of the grabbed raw sensor data, the second histogram shows the statistic distribution of the image data after additional FPN correction / color demosaicing and color processing.
4.4 File I/O

4.4.1 Load Image

The IP3-Control software can load the image data in following format:
- Windows Bitmap, grey scaled with 8 bit/pixel
- Sensor Raw Data, 16 bit/pixel (extension *.idt)
- Sensor Subframe Raw Data, 16 bit/pixel (extension *.ids)

4.4.2 Save Image

The IP3-Control software can store the image data in following format:
- Windows Bitmap, grey scaled with 8 bit/pixel
- Tif Format, Raw Data, grey scaled with 16 bit/pixel
  The image data are MSB mapped.
- Software FPN corrected and uncorrected Sensor Raw Data,
  16 bit/pixel (extension *.idt)
- Software FPN corrected and uncorrected Sensor Subframe Raw Data,
  16 bit/pixel (extension *.ids)

There are two different *.idt / *.ids file formats available, Sensor Raw Data and Corrected Sensor Raw Data. The Corrected data are stored after the software FPN correction. Please pay attention if you store corrected and raw sensor data.

The *.ids files includes a 16 byte image header with information about the sensor frame width, height, x start- and y start position.

If you use the Tif format it is also possible to store corrected or uncorrected sensor raw data. It depends on the software FPN setting of the FPN Window.
4.5 Zoom Function

The zoom item allows the user to look at an area of interest (aoi) of the whole image. To selection an aoi, you have to select a rectangle in the main display window.

The aoi is displayed in a separate zoom window and can be zoomed in the steps by 100%, 200%, 300%, 400%, 500% and 800%.
If the menu item “Live Zoom” is checked and the continuous acquisition grab has been activated the zoom window will also display the new grabbed data.
4.6 Movies

The software has the functionality to record sequences, store them after the recording to disc and replay them applying all image optimizing functions.

4.6.1 Movie Player

The Play List allows the user to load, show and convert a sequence of *.idt or *.ids images into windows bitmaps, using the actual LUT settings.

The image player supports following formats:

- **Image Data Subframe (*.ids)**
  - 16 Bit/ Pixel
  - variable size format, the start position and frame size dimensions are stored in the header of the image file

- **Image Data (*.idt)**
  - 16 Bit/ Pixel
  - Fixed size format:
    - Width = 640
    - Height = 480
    - Includes no information about the image start coordinates

- **Windows Bitmap (*.bmp)**
  - only 8 Bit/ Pixel (grey image) supported
To load or add a sequence, single image select Sequence ⇒ Define or Sequence ⇒ Merge Sequence. All new loaded files will be automatically selected. The selected images will be played once or endless, if the “play endless” function has been enabled (Sequence ⇒ Play Endless).

Only if the image size is different from the actual used FPN correction format, the user will get an information message. The FPN correction will disabled by the software. After deactivating the actual FPN correction, the user has to activate it manually. The software is not able to verify, if the actual used FPN correction will match to the played scene. It is also possible to load the appropriate FPN correction from file.

4.6.2 Recording Sequences

To activate the recording select in the menu Record ⇒ Start or press the record button. The image recording will start at once. At first “Count Images” will be stored to main PC memory. After that, the files will be stored with a user defined file name in *.ids format. There will also add an incrementing record number (six digits) at the end of each file.

The sequence can be manual converted to a bitmap sequence, using the actual Lut settings (Sequence ⇒ Convert To Bitmap).

The info window informs the user about the actual memory status of the PC memory, the actual camera frame size and the max. count of images to record. 50 MB of PC memory are still reserved for the OS.
4.7 Camera Control

The camera control modul allows the user to control the camera settings such as frame size or frame syncs.
For image displaying it is required that the width length must be divisible by four.

![Camera Control Window](image)

Figure 18: Camera Control Window

4.8 Info

This menu item opens the “Info About” Window. It shows the actually software version and its last compilation date.

![Info About Window](image)

Figure 19: Info About Window